Can a debian package have a dependency on a snap package?

by S. Adams   Last Updated April 10, 2018 20:02 PM

We have an application that is packaged as a debian (.deb) package. The application is deployed on Ubuntu 14.04 LTS.

We are looking to provide the application on 16.04 when it is released. However, one of the applications's dependencies -- couchdb -- is available as a snap package and not as a debian package.

Is there a way to tell the debian package that it requires a particular snap to be installed?

Tags : deb snap


Related Questions


What is ‘Snap’ packaging format?

Updated April 23, 2016 10:00 AM



A snap package with root right start

Updated January 11, 2017 10:00 AM