can't get libgdk-pixbuf2.0-dev to install

by Omar Khan   Last Updated October 09, 2019 20:02 PM

I am trying to compile a C file that has a header file containing the following line:

#include <gdk-pixbuf/gdk-pixbuf.h>

apparently I need to install libgdk-pixbuf2.0-dev but when I try to install I get the following error

sudo apt-get install libgdk-pixbuf2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgdk-pixbuf2.0-dev : Depends: libgdk-pixbuf2.0-0 (= 2.32.2-1ubuntu1.5) but 2.32.2-1ubuntu1.6 is to be installed
                        Depends: gir1.2-gdkpixbuf-2.0 (= 2.32.2-1ubuntu1.5) but 2.32.2-1ubuntu1.6 is to be installed
                        Depends: libx11-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

any ideas on how to resolve this or how to get the file to compile on my computer?



Related Questions




Trouble installing VLC

Updated May 29, 2015 00:00 AM

Boost unmet dependencies

Updated October 05, 2015 09:01 AM