NFS does not see underlying NTFS

by Abrackadabra   Last Updated November 11, 2017 08:02 AM

I have an internet sharing server which is connected with a hdd with music I'd like to listen via wifi.

I have tried creating a samba or ftp share, but they are so slow (or I just do not know how to make them faster =) ). So I have tried to share via NFS.

I have followed this guide: https://www.digitalocean.com/community/articles/how-to-set-up-an-nfs-mount-on-ubuntu-12-04, and I was able to connect, but when I go into a dir, to where my hdd is mounted, I can see nothing.

On server:

/srv/share ➜  ls -l 
total 24
drwxrwxrwx 1 root root 24576 Apr  2 16:15 hdd
-rw-rw-r-- 1 abra abra     0 Apr 16 21:22 hello
-rw-rw-r-- 1 abra abra     0 Apr 16 21:19 hi
/srv/share ➜  ls hdd
...various dirs...

On client:

~/server ➜  ls -l
total 4
drwxrwxr-x 2 abra abra 4096 Apr 16 21:19 hdd
-rw-rw-r-- 1 abra abra    0 Apr 16 21:22 hello
-rw-rw-r-- 1 abra abra    0 Apr 16 21:19 hi
~/server ➜  ls hdd
~/server ➜      

Or maybe NTS is just an overkill and there is an easier way to share mounted hdd fast via wifi?

Thanks in advance.

EDIT:

My /etc/exports

# /etc/exports: the access control list for filesystems which may be exported
#       to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/srv/share  192.168.0.0/24(rw,nohide,insecure,no_subtree_check,sync)
Tags : server mount ntfs nfs


Answers 2


I've just had to add

/srv/share/hdd  192.168.0.0/24(rw,nohide,insecure,no_subtree_check,sync)

in /etc/exports and it works.

There is an option crossmount to add in exports, but I didn't manage to get it work.

Abrackadabra
Abrackadabra
April 17, 2013 19:49 PM

I have the same problem and did not realize what is the solution... I have Ubuntu Server 17.10 with many features also NFS Server is running at home. Also I have 1Tb mounted volume on point /home/myaccount/hdd. All is OK but clients do not see mounted volume. /etc/exports is: /home/myaccount 192.168.1.0/24(rw,insecure,nohide,all_squash,anonuid=1000,anongid=1000,no_subtree_check). What's wrong?

Игорь Кривошея
Игорь Кривошея
November 11, 2017 07:38 AM

Related Questions





What causes high CPU usage by mount.ntfs?

Updated November 28, 2017 13:02 PM

can't mount ntfs flash drive to embedded device

Updated March 27, 2015 08:00 AM